PunBB Installation and Upgrade Instructions

From PunBB Resource Wiki

Jump to: navigation, search

Instructions for the installation of PunBB 1.2.23 and for upgrading from previous versions.

Contents

Requirements

MySQL: PunBB will not work at all with any version prior to 3.23.17.

PostgreSQL: PunBB 1.2.* has been thoroughly tested on various versions between 7.3.3 and 7.4.5, but it should work fine with any version greater than 7.0. Please note that PHP 4.3.0 or later is required for PostgreSQL support.

SQLite: PunBB 1.2.* has only been thoroughly tested on versions 2.8.11 and 2.8.14 of SQLite, but should work with basically any version.


Installation

  1. Copy/upload all contents of the directory upload/ into the directory where you want to run your forums.
  2. Run install.php from the forum root directory (e.g. open http://mydomain/myforums/install.php in your browser). Follow the instructions.

Please report any problems you might encounter during installation in the PunBB.org Support Forums.


Upgrading

From 1.0

In order to upgrade from PunBB 1.0.* to 1.2.23, you must first update your current installation to 1.1. Download PunBB 1.1 from the PunBB.org downloads page and follow the upgrade instructions in the included install.html.

From 1.1

In order to upgrade from PunBB 1.1.* to 1.2.23, you must first update your current installation to 1.2. Download PunBB 1.2 from the PunBB.org downloads page and follow the upgrade instructions in the included install.html.

From 1.2.*

Follow these instructions to update your current 1.2.* installation to 1.2.23.

NOTE: Make a backup of your current forum directory before proceeding. Also, don't forget to make a backup of your forum database. Use the tool mysqldump for MySQL and pg_dump if you are using PostgreSQL. If you're using SQLite, just make a backup copy of the SQLite database file. You can also make database backups via most administration tools such as MySQL Workbench, phpMyAdmin and phpPgAdmin.

  1. Copy/upload all contents of the directory upload/ into your old 1.2 directory (overwriting any existing files).
  2. Copy/upload the script 12_to_1223_update.php from the directory extras/ to the forum root directory and run it through your browser. Follow the instructions. Once the update script has finished you should remove the script from the forum root directory.

You should now be running PunBB 1.2.23.


Maximizing Performance

Here are some recommendations for maximizing the performance of PunBB.

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox